// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^UC(?:T|F[LCA]?|PA?)\d{3}$").unwrap();
let string = "UCF123
UCP123
UCT123
UCFL123
UCFC123
UCFA123
UCPA123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}