import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ix)<img\\s\n"
+ "(?:(?=[^>]*?\\btitle\\s*=\\s*(?|\"\\s*([^\"]*?)\\s*\"|'\\s*([^']*?)\\s*')))?\n"
+ "(?:(?=[^>]*?\\balt\\s*=\\s*(?|\"\\s*([^\"]*?)\\s*\"|'\\s*([^']*?)\\s*')))?\n"
+ "[^>]*?\\bsrc\\s*=\\s*(?|\"\\s*([^\"]*?)\\s*\"|'\\s*([^']*?)\\s*')[^>]*>";
final String string = "<img src=\"landscape.jpg\">\n"
+ "<img alt = \"some landscape \" src=\"landscape.jpg\">\n"
+ "<img src=\"landscape.jpg\" title=\" My landscape \" >\n"
+ "<img alt = \" some landscape \" src=\" landscape.jpg \" title=\"My landscape\">\n"
+ "<img title = 'My landscape' alt = \"some landscape\" src = 'landscape.jpg'>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}