$re = '/(?ix)<img\s
(?:(?=[^>]*?\btitle\s*=\s*(?|"\s*([^"]*?)\s*"|\'\s*([^\']*?)\s*\')))?
(?:(?=[^>]*?\balt\s*=\s*(?|"\s*([^"]*?)\s*"|\'\s*([^\']*?)\s*\')))?
[^>]*?\bsrc\s*=\s*(?|"\s*([^"]*?)\s*"|\'\s*([^\']*?)\s*\')[^>]*>/';
$str = '<img src="landscape.jpg">
<img alt = "some landscape " src="landscape.jpg">
<img src="landscape.jpg" title=" My landscape " >
<img alt = " some landscape " src=" landscape.jpg " title="My landscape">
<img title = \'My landscape\' alt = "some landscape" src = \'landscape.jpg\'>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);