package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(<script.*?)(<\/script>)`)
var str = `<div class="body">
<div class="product-essential">
// Data needed
</div>
<script type="text/javascript">
// Some javascript code executing
</script>
</div> `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}