re = /(<script.*?)(<\/script>)/
str = '<div class="body">
<div class="product-essential">
// Data needed
</div>
<script type="text/javascript">
// Some javascript code executing
</script>
</div> '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end