# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(faturou\s|faturamento de\s|faturei\s|de um faturamento )*(mais\sde\s)*(((((R\$)+(\s)*(\d){1,6}(\s)*((\.|\,)*\d{1,3}|k|mil)*)))+|((de\s(\d){1,3}(k|mil)\spara\s(\d){1,3}(k|mil)))+)(\sde\sfaturamento)*(\sem\s(menos\sde\s)*(\d{1,2})\sdias)*(\sfoi o que a minha (aluna|cliente|mentoranda|mentorada)+ faturou)*(\sapós o curso)*"
test_str = ("(já\\s)*(como\\s)*(em\\sum\\s[u|ú]nico\\sdia\\s(minha\\smentoreanda\\s)*\n\n\n"
"mentorada faturou\n"
"Foram mais de R$50.000 após o curso\n"
"mentora que já faturou mais de R$ 670(com ou sem espaço)mil\n"
"Assim como eu sai de um faturamento de 10k para 300k\n"
"mentora que já faturei mais de R$ 670.000,00(com ou sem espaço)mil\n"
"Em 2022 R$1950 tudo isso por conta da mudança de posicionamento\n"
"Em um único dia minha mentoreanda faturou R$9.600\n"
"R$62.000 em 30 dias\n"
"R$62k em 30 dias\n"
"R$62 k em 30 dias\n"
"R$62mil em 30 dias\n"
"R$62 mil em 30 dias\n"
"R$5.014 foi o que a minha aluna faturou\n"
"R$12.000 de faturamento em menos de 15 dias de aplicação\n"
"faturou R$62.000 em 30 dias\n"
"faturei R$62k em 30 dias\n"
"faturamento de R$62 k em 30 dias\n"
"R$62mil em 30 dias\n"
"R$62 mil em 30 dias\n"
"R$5.014 foi o que a minha aluna faturou\n"
"R$12.000 de faturamento em menos de 15 dias de aplicação\n"
"Esse foi o resultado da @ utilizando o (meu) método\n\n\n\n"
"77k em 25 dias de aplicação\n\n\n"
"(já\\s|como\\seu\\ssai\\sde\\sum\\s|em\\sum\\s[u|ú]nico\\sdia\\s(minha\\smentoreanda\\s|mentorada\\s))*\n"
"Reais\n"
"(((R\\$)+(\\s)*(\\d){1,6}(\\s)*((\\.|\\,)*\\d{1,3}|k|mil)*))+\n"
"parte decimal\n"
"((\\.)(\\d){1,3}|(\\,)(\\d){1,3})*\n"
"de tanto a tanto\n"
"(de(\\d){1,3}\\spara\\s(\\d){1,3})+\n\n\n"
"((((R\\$)+(\\s)*(\\d){1,6}((\\.)(\\d){1,3}|(\\,)(\\d){1,3})*(\\s)*(k|mil)*))+|(de(\\d){1,3}\\spara\\s(\\d){1,3})+)\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.