$re = '/hello world
/m';
$str = '\\\\mathrm l >\\\\mathrm li ^ + >\\\\mathrm mg ^ +>\\\\mathrm a \\\\beta+ \\\\mathrm co';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);