// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)hello world
").unwrap();
let string = "\\\\mathrm l >\\\\mathrm li ^ + >\\\\mathrm mg ^ +>\\\\mathrm a \\\\beta+ \\\\mathrm co";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}