use strict;
my $str = 'Nel 1996 i governatori della) BERS hanno deciso di raddoppiare il capitale autorizzato della Banca, a) per il quale l\'Unione ha sottoscritto ulteriori 3 000 azioni del i) valore di 1 000 EUR ciascuna.
26.10
26.10.2302
°
Conformément à l’article 14, paragraphe 5 bis, du règlement de base, à moins qu’elle ne dispose d’éléments de preuve suffisants au sens de l’article 5 démontrant que les conditions prévues à l’article 10, paragraphe 4, points c) ou d), ne sont pas remplies, la Commission enregistre les importations faisant l’objet d’une enquête antidumping au cours de la période de notification préalable.
12.88 Les esters (d’alkylphosphate sont définis comme étant certains esters d’alkylphosphate fabriqués exclusivement sur des chaînes (latérales d’une longueur de deux ou trois atomes de carbone (y compris les chaînes alkylées chlorées) et ayant une teneur en phosphore d’au moins 9 % (en poids) et une viscosité comprise entre 1 et 100 mPa.s à 20-25 °), relevant des numéros CAS 13674-84-5, 1244733-77-4 et 78-40-0.
Selon une communication de Kingspan, une quantité moindre de TEP est nécessaire pour remplacer le TCPP (environ 1,8 kg de TCPP est nécessaire pour remplacer 1 kg de TEP), ce qui compenserait partiellement le coût de production plus élevé du TEP.
La production totale de (l’Union au cours de la période d’enquête s’est établie à environ 18.274 tonnes.
(i) Conformément à l’article (l 14, paragraphe 5a, du règlement de base, à moins qu’elle ne dispose d’éléments de preuve suffisants) au sens de l’article 5 démontrant que les conditions prévues à l’article 10, paragraphe 4, points (c) ou (d), 1234 ne sont pas remplies, la Commission enregistre les importations faisant l’objet d’une enquête antidumping au cours de la période de notification préalable).
du règlement (UE) 2015/755 du Parlement européen et du Conseil
i) allala
Lalala) not lalala, (and lalala.
Lalala not lalala, (and lalala
Ok, (here\'s some context. I need regex that will match the missing opening bracket here: \'Here, since I\'m so good at tpying), I forgot to open the brackets.\' but not here: \'du (Parlement européen) et du Conseil.';
my $regex = qr/(\A|\)|\.)[^\(]*?(?:[a-z]{2,})\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}