# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\A|\)|\.)[^\(]*?(?:[a-z]{2,})\)"
test_str = ("Nel 1996 i governatori della) BERS hanno deciso di raddoppiare il capitale autorizzato della Banca, a) per il quale l'Unione ha sottoscritto ulteriori 3 000 azioni del i) valore di 1 000 EUR ciascuna.\n"
"26.10\n"
"26.10.2302\n"
"°\n"
"Conformément à l’article 14, paragraphe 5 bis, du règlement de base, à moins qu’elle ne dispose d’éléments de preuve suffisants au sens de l’article 5 démontrant que les conditions prévues à l’article 10, paragraphe 4, points c) ou d), ne sont pas remplies, la Commission enregistre les importations faisant l’objet d’une enquête antidumping au cours de la période de notification préalable.\n\n"
"12.88 Les esters (d’alkylphosphate sont définis comme étant certains esters d’alkylphosphate fabriqués exclusivement sur des chaînes (latérales d’une longueur de deux ou trois atomes de carbone (y compris les chaînes alkylées chlorées) et ayant une teneur en phosphore d’au moins 9 % (en poids) et une viscosité comprise entre 1 et 100 mPa.s à 20-25 °), relevant des numéros CAS 13674-84-5, 1244733-77-4 et 78-40-0.\n"
"Selon une communication de Kingspan, une quantité moindre de TEP est nécessaire pour remplacer le TCPP (environ 1,8 kg de TCPP est nécessaire pour remplacer 1 kg de TEP), ce qui compenserait partiellement le coût de production plus élevé du TEP.\n"
"La production totale de (l’Union au cours de la période d’enquête s’est établie à environ 18.274 tonnes.\n"
"(i) Conformément à l’article (l 14, paragraphe 5a, du règlement de base, à moins qu’elle ne dispose d’éléments de preuve suffisants) au sens de l’article 5 démontrant que les conditions prévues à l’article 10, paragraphe 4, points (c) ou (d), 1234 ne sont pas remplies, la Commission enregistre les importations faisant l’objet d’une enquête antidumping au cours de la période de notification préalable).\n"
"du règlement (UE) 2015/755 du Parlement européen et du Conseil\n"
"i) allala\n"
"Lalala) not lalala, (and lalala.\n"
"Lalala not lalala, (and lalala\n"
"Ok, (here's some context. I need regex that will match the missing opening bracket here: 'Here, since I'm so good at tpying), I forgot to open the brackets.' but not here: 'du (Parlement européen) et du Conseil.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.