# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\w+-gradient\(.*?\)\)|\w+-gradient\(.*?\)"
test_str = ("Only Match CSS gradients ignoring everything else.\n\n"
"EXAMPLES\n\n"
"2 and 3+ colors any type (4 matches): \\w+-gradient\\(.*?\\)\\)|\\w+-gradient\\(.*?\\)\n"
"3+ colors linear (1 match): linear-gradient\\(.*?\\)\\)\n"
"2 colors linear (4 matches): linear-gradient\\(.*?\\)\n"
"2 colors any type (4 matches): \\w+-gradient\\(.*?\\)\n\n"
"---\n\n"
"linear-gradient(148deg, #c2fd88 24%, #89fc80 100%); //green\n"
"linear-gradient(148deg, #fff 24%, #000 100%); //gray\n"
"`background-image: linear-gradient(to right, rgb(236, 72, 153), rgb(239, 68, 68), rgb(234, 179, 8));`\n"
"$highlight-rainbow: conic-gradient(from 195.94deg at 50% 50%, #FF1B71 -28.98deg, #E0201A 0.41deg, #EE3F16 27.93deg, #FF6128 54.73deg, #FDA206 88.8deg, #FFED00 117.65deg, #DFF051 145.77deg, #17AB70 175.77deg, #1A8F9C 207.65deg, #005AFF 239.36deg, #5C4ECE 274.87deg, #582C86 304.33deg, #FF1B71 331.02deg, #E0201A 360.41deg);\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.