// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\w+-gradient\(.*?\)\)|\w+-gradient\(.*?\)").unwrap();
let string = "Only Match CSS gradients ignoring everything else.
EXAMPLES
2 and 3+ colors any type (4 matches): \\w+-gradient\\(.*?\\)\\)|\\w+-gradient\\(.*?\\)
3+ colors linear (1 match): linear-gradient\\(.*?\\)\\)
2 colors linear (4 matches): linear-gradient\\(.*?\\)
2 colors any type (4 matches): \\w+-gradient\\(.*?\\)
---
linear-gradient(148deg, #c2fd88 24%, #89fc80 100%); //green
linear-gradient(148deg, #fff 24%, #000 100%); //gray
`background-image: linear-gradient(to right, rgb(236, 72, 153), rgb(239, 68, 68), rgb(234, 179, 8));`
$highlight-rainbow: conic-gradient(from 195.94deg at 50% 50%, #FF1B71 -28.98deg, #E0201A 0.41deg, #EE3F16 27.93deg, #FF6128 54.73deg, #FDA206 88.8deg, #FFED00 117.65deg, #DFF051 145.77deg, #17AB70 175.77deg, #1A8F9C 207.65deg, #005AFF 239.36deg, #5C4ECE 274.87deg, #582C86 304.33deg, #FF1B71 331.02deg, #E0201A 360.41deg);
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}