#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\\')?[^']*(?<!\\)'((?:\\[^']|[^ֿֿֿֿֿֿֿֿ\\']|\\')*)'|'((?:[^'\\]*\\'[^'\\]*)+)'"
Local $sString = "'test' " & @CRLF & _
"more'test' " & @CRLF & _
"'test'more " & @CRLF & _
"\'no'yes' " & @CRLF & _
"a 'one' and 'two' and 'three'... " & @CRLF & _
"nothing at all " & @CRLF & _
"'' " & @CRLF & _
"''test " & @CRLF & _
"test'' " & @CRLF & _
"te''st " & @CRLF & _
"'This is not wrong' and 'this isn\'t either' " & @CRLF & _
"'tw\'o repl\'acements' in 't\'wo stri\'ngs'. " & @CRLF & _
"'\\'' " & @CRLF & _
"''' " & @CRLF & _
"'test1'\n'test2' " & @CRLF & _
"'''' " & @CRLF & _
"" & @CRLF & _
"GVNBR!a4GO'Ic1>7E<9?l)gaj0%4*{dX2+6s&__F8-IZk.^|A528/!fc_b#<uO0C[Vod;ws0eqL$#(J28>d^l#421[6EwbnZH/zTP>\",&e&Qx^K!yd2!dX;z.,r)Qb2=f0Xz**R |DB?NOUAG6yvGU1bX`m5hE@/\"uIm=hp{K]17L-L5v=eI#!{Q^O5To1!0sJ!{kl~_yV&N&=oTr$?Ou[niG"'D0"/ZJZUey3{O04JkM8j/S7\"wqs&LhHBxxnX/l}*1-rF)ou/JeWx-*C!Sp1db|1Tcd6xYf f" & @CRLF & _
"" & @CRLF & _
"{;nF, yy]fKAf<6H]T74R}1k#HUIc|]Rqz-Ce72-D%vz&Nm rw=81:1_Y&e,34pL.amQmAoj*m;6ObGN]#u71j%+H\'}4}b~|nTy]<B7umVMx;tN%QUPY=P`67F4Rert4Cy'PMOJwnmc2s\'4f<EEmh,yj3Uf/u[lbc/dAgl*Xd%oY,T;+\"2_f{BzP`.#v(yGtX\'O+4eU[P.3&1s+ xm!" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")