import re
regex = re.compile(r"(?:\\')?[^']*(?<!\\)'((?:\\[^']|[^ֿֿֿֿֿֿֿֿ\\']|\\')*)'|'((?:[^'\\]*\\'[^'\\]*)+)'", flags=re.MULTILINE)
test_str = ("'test' \n"
"more'test' \n"
"'test'more \n"
"\\'no'yes' \n"
"a 'one' and 'two' and 'three'... \n"
"nothing at all \n"
"'' \n"
"''test \n"
"test'' \n"
"te''st \n"
"'This is not wrong' and 'this isn\\'t either' \n"
"'tw\\'o repl\\'acements' in 't\\'wo stri\\'ngs'. \n"
"'\\\\'' \n"
"''' \n"
"'test1'\\n'test2' \n"
"'''' \n\n"
"GVNBR!a4GO'Ic1>7E<9?l)gaj0%4*{dX2+6s&__F8-IZk.^|A528/!fc_b#<uO0C[Vod;ws0eqL$#(J28>d^l#421[6EwbnZH/zTP>\\\",&e&Qx^K!yd2!dX;z.,r)Qb2=f0Xz**R |DB?NOUAG6yvGU1bX`m5hE@/\\\"uIm=hp{K]17L-L5v=eI#!{Q^O5To1!0sJ!{kl~_yV&N&=oTr$?Ou[niG\"'D0\"/ZJZUey3{O04JkM8j/S7\\\"wqs&LhHBxxnX/l}*1-rF)ou/JeWx-*C!Sp1db|1Tcd6xYf f\n\n"
"{;nF, yy]fKAf<6H]T74R}1k#HUIc|]Rqz-Ce72-D%vz&Nm rw=81:1_Y&e,34pL.amQmAoj*m;6ObGN]#u71j%+H\\'}4}b~|nTy]<B7umVMx;tN%QUPY=P`67F4Rert4Cy'PMOJwnmc2s\\'4f<EEmh,yj3Uf/u[lbc/dAgl*Xd%oY,T;+\\\"2_f{BzP`.#v(yGtX\\'O+4eU[P.3&1s+ xm!\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")