# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^P(?!$)((\d+Y)|(\d+\.\d+Y$))?((\d+M)|(\d+\.\d+M$))?((\d+W)|(\d+\.\d+W$))?((\d+D)|(\d+\.\d+D$))?(T(?=\d)((\d+H)|(\d+\.\d+H$))?((\d+M)|(\d+\.\d+M$))?(\d+(\.\d+)?S)?)??$"
test_str = ("P1Y\n"
"P1.4Y\n"
"P1.4Y2M\n"
"P14Y2.5M\n"
"P14Y2.5MT1M\n"
"P2MT30M\n"
"P2MT30.5M\n"
"P2MT30.5M3S\n"
"PT6H\n"
"PT6.5H\n"
"PT6.5H12S\n"
"P5W\n"
"P5.2W\n"
"P5.2W1D\n"
"P3Y29DT4H35M59S\n"
"P1Y1M1DT2H12M34.23S\n\n\n"
"P\n"
"PT\n"
"P3MT")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.