import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "---:\\n.*?---(\\n|$)";
final String string = "---:\n"
+ "TS : 150602000006S\n"
+ "EC1: 02429.523\n"
+ "EC2: 05604.110\n"
+ "---\n"
+ "---:\n"
+ "TS : 150603000006S\n"
+ "---:\n"
+ "TS : 150603000006S\n"
+ "EP1: 3333.523\n"
+ "---";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}