re = /---:\n.*?---(\n|$)/
str = '---:
TS : 150602000006S
EC1: 02429.523
EC2: 05604.110
---
---:
TS : 150603000006S
---:
TS : 150603000006S
EP1: 3333.523
---'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end