using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<datetime>\d{2}/\d{2}/\d{4}[^-]+)\s+-\s+(?P<name>[^:]+):\s+(?P<message>[\s\S]+?)(?=^\d{2}|\Z)";
string input = @"03/01/2021, 10:06 - Messages and calls are end-to-end encrypted. No one outside of this chat, not even WhatsApp, can read or listen to them. Tap to learn more.
21/06/2018, 07:47 - +234 806 679 5599 created group ""Keremor Barging""
03/01/2021, 08:48 - John C. added you
03/01/2021, 08:49 - +234 703 803 5040: Waiting for this message
03/01/2021, 08:49 - +234 703 803 5040: Waiting for this 03/01/2021 message
04/01/2021, 08:06 - +234 703 803 5040:Ugo-Ocha Terminal.
No STS operation was carried out.
Total volume Onboard Ugo Ocha As at 0800hrs 04/01/2021 remain the same";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}