import re
regex = re.compile(r"^(?P<datetime>\d{2}/\d{2}/\d{4}[^-]+)\s+-\s+(?P<name>[^:]+):\s+(?P<message>[\s\S]+?)(?=^\d{2}|\Z)", flags=re.MULTILINE)
test_str = ("03/01/2021, 10:06 - Messages and calls are end-to-end encrypted. No one outside of this chat, not even WhatsApp, can read or listen to them. Tap to learn more.\n"
"21/06/2018, 07:47 - +234 806 679 5599 created group \"Keremor Barging\"\n"
"03/01/2021, 08:48 - John C. added you\n"
"03/01/2021, 08:49 - +234 703 803 5040: Waiting for this message\n"
"03/01/2021, 08:49 - +234 703 803 5040: Waiting for this 03/01/2021 message\n"
"04/01/2021, 08:06 - +234 703 803 5040:Ugo-Ocha Terminal. \n\n"
"No STS operation was carried out.\n\n"
"Total volume Onboard Ugo Ocha As at 0800hrs 04/01/2021 remain the same")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")