using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\*\*(?=[\w|\s])";
string substitution = @"";
string input = @"I'm searching for **my 12 *funny* words inside my** unfunny text
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}