#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!-)(0,\d*[0-9])|(?<!0)([1-9]\d*,\d*)|(-[0-9],\d*?[1-9]\d*)|(-[1-9]\d*,{0,1}\d*)|\b(?<!-)(0)[a-zA-Z,\n]"
Local $sString = "Deverá aceitar:" & @CRLF & _
"" & @CRLF & _
"0" & @CRLF & _
"0," & @CRLF & _
"0,0" & @CRLF & _
"0,00" & @CRLF & _
"0,010" & @CRLF & _
"0,00000000000000000000002" & @CRLF & _
"0,01 até " & @CRLF & _
"0,99" & @CRLF & _
"0,1" & @CRLF & _
"1234567890,99" & @CRLF & _
"-1234567890,99" & @CRLF & _
"-0,01 até " & @CRLF & _
"-0,99" & @CRLF & _
"1,00" & @CRLF & _
"-1,00" & @CRLF & _
"-1,012" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Não poderá aceitar:" & @CRLF & _
"" & @CRLF & _
"-0" & @CRLF & _
"-0," & @CRLF & _
"-0,00" & @CRLF & _
"-,01 a -,99" & @CRLF & _
"//Sequencia vazio" & @CRLF & _
"01,00" & @CRLF & _
"01" & @CRLF & _
"0012"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")