import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!-)(0,\\d*[0-9])|(?<!0)([1-9]\\d*,\\d*)|(-[0-9],\\d*?[1-9]\\d*)|(-[1-9]\\d*,{0,1}\\d*)|\\b(?<!-)(0)[a-zA-Z,\\n]";
final String string = "Deverá aceitar:\n\n"
+ "0\n"
+ "0,\n"
+ "0,0\n"
+ "0,00\n"
+ "0,010\n"
+ "0,00000000000000000000002\n"
+ "0,01 até \n"
+ "0,99\n"
+ "0,1\n"
+ "1234567890,99\n"
+ "-1234567890,99\n"
+ "-0,01 até \n"
+ "-0,99\n"
+ "1,00\n"
+ "-1,00\n"
+ "-1,012\n\n\n"
+ "Não poderá aceitar:\n\n"
+ "-0\n"
+ "-0,\n"
+ "-0,00\n"
+ "-,01 a -,99\n"
+ "//Sequencia vazio\n"
+ "01,00\n"
+ "01\n"
+ "0012";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}