import re
regex = re.compile(r"(?m)^(?:https?://)?(?:www\.)?(.*\.(?:com|org|org))$")
test_str = ("http://www.askoxford.com\n"
"http://www.hydrogencarsnow.com\n"
"http://www.bnsf.com\n"
"http://web.archive.org")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")