re = /(?m)^(?:https?:\/\/)?(?:www\.)?(.*\.(?:com|org|org))$/
str = 'http://www.askoxford.com
http://www.hydrogencarsnow.com
http://www.bnsf.com
http://web.archive.org'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end