package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(a)?b(?(1)c|d)`)
var str = `abc
abd
bd
bc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}