$re = '~(a)?b(?(1)c|d)~m';
$str = 'abc
abd
bd
bc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);