package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\S+\s)?\S*(?:IN|[<=>]+)\s(?:(?:\([^)]+\))|\S+)`)
var str = `where c.value IN (3,4,5,6)
Where c.value = 32
SELECT C.NAME, C.FIRSTNAME FROM CUSTOMER C, PROSPECT P WHERE C.ID = 32 AND C.TRUC = 28 AND P.ID < 12 AND P.A IN (2, 3, 4)
WHERE C.ID <= 32 AND C.TRUC >= 28 AND P.ID < 12 AND P.ID > 12 AND P.ID = 12 AND P.A IN (2, 3, 4)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}