const regex = /(?:\S+\s)?\S*(?:IN|[<=>]+)\s(?:(?:\([^)]+\))|\S+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\S+\\s)?\\S*(?:IN|[<=>]+)\\s(?:(?:\\([^)]+\\))|\\S+)', 'g')
const str = `where c.value IN (3,4,5,6)
Where c.value = 32
SELECT C.NAME, C.FIRSTNAME FROM CUSTOMER C, PROSPECT P WHERE C.ID = 32 AND C.TRUC = 28 AND P.ID < 12 AND P.A IN (2, 3, 4)
WHERE C.ID <= 32 AND C.TRUC >= 28 AND P.ID < 12 AND P.ID > 12 AND P.ID = 12 AND P.A IN (2, 3, 4)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}