import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[ \\t]*[\\r\\n]+";
final String string = " P0:::inicial\n"
+ " P1:::pregunta\n"
+ " P2:::pregunta\n"
+ " P3:::pregunta\n"
+ " R1:::respuesta\n"
+ " R2:::respuesta\n"
+ " R3:::respuesta\n"
+ " R4:::respuesta\n"
+ " R5:::respuesta\n"
+ " R6:::respuesta\n"
+ " R7:::respuesta\n"
+ " R8:::respuesta\n"
+ " R9:::respuesta\n"
+ " C1:::cotizacion\n"
+ " C2:::cotizacion\n"
+ " C3:::cotizacion\n"
+ " A1:::agregar\n"
+ " A2:::agregar\n"
+ " \n"
+ " C4:::cotizacion";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}