$re = '/^[ \t]*[\r\n]+/m';
$str = ' P0:::inicial
P1:::pregunta
P2:::pregunta
P3:::pregunta
R1:::respuesta
R2:::respuesta
R3:::respuesta
R4:::respuesta
R5:::respuesta
R6:::respuesta
R7:::respuesta
R8:::respuesta
R9:::respuesta
C1:::cotizacion
C2:::cotizacion
C3:::cotizacion
A1:::agregar
A2:::agregar
C4:::cotizacion';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;