$re = '/[^\\\\]*(?=[.][a-zA-Z]+$)/m';
$str = 'c:\\temp\\some.file.name.with.periods.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);