re = /[^\\]*(?=[.][a-zA-Z]+$)/m
str = 'c:\\temp\\some.file.name.with.periods.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end