const regex = /(^02.{0}|^01.{1}|^0505.{0}|[0-9]{3})([0-9]+)([0-9]{4})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^02.{0}|^01.{1}|^0505.{0}|[0-9]{3})([0-9]+)([0-9]{4})', '')
const str = `010111122222`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}