re = /(^02.{0}|^01.{1}|^0505.{0}|[0-9]{3})([0-9]+)([0-9]{4})/
str = '010111122222'
# Print the match result
str.match(re) do |match|
puts match.to_s
end