$re = '/^[A-Za-z]+:[0-9]+(?<=^.{10})/m';
$str = 'A:12345678
A:123456789
FOO:567890s123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);