re = /^[A-Za-z]+:[0-9]+(?<=^.{10})/m
str = 'A:12345678
A:123456789
FOO:567890s123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end