import Foundation
let pattern = #"\<.+\>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"彼女は<font color="#ff0000"><font color="#ff0000">看護婦</font></font>です。"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}