use strict;
my $str = 'name&|surna.me|ag,e';
my $regex = qr/[^a-zA-Z0-9|]+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";