import re
regex = re.compile(r"[^a-zA-Z0-9|]+")
test_str = "name&|surna.me|ag,e"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)