using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![ -]|\d+$)[[:alnum:] -]+(?<![ -])$";
string input = @"Street
Some-Street
Street
1 st street
street 5
Street
Street
Street-
-Street
111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}