re = /^(?![ -]|\d+$)[[:alnum:] -]+(?<![ -])$/m
str = 'Street
Some-Street
Street
1 st street
street 5
Street
Street
Street-
-Street
111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end