import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{4}-\\d\\d-\\d\\d(?:t[\\d:.]*(?:z|[+-]\\d\\d:?\\d\\d)?)?$";
final String string = "2014-12-23\n"
+ "2014-12-23t\n"
+ "2014-12-23T\n"
+ "2014-12-23Tz\n"
+ "2014-12-23T12:22.222Z\n"
+ "2014-12-23T12:22.222-22:22\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}