import re
regex = re.compile(r"^\d{4}-\d\d-\d\d(?:t[\d:.]*(?:z|[+-]\d\d:?\d\d)?)?$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("2014-12-23\n"
"2014-12-23t\n"
"2014-12-23T\n"
"2014-12-23Tz\n"
"2014-12-23T12:22.222Z\n"
"2014-12-23T12:22.222-22:22\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")