$re = '/token=(.*?)&filter=\s*(.+?)\s+(.+)/m';
$str = 'api/evenSession/123123123/eventSession?token=1234656&filter= chris moreno';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);