package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*(-(W|R)( |")(([0-9a-fA-F]{2}) ){2,20}).*`)
var str = `pnscan -W"05 5A 37" -R"FF 00 FF" 192.168.0.32 145
/usr/local/bin/pnscan -t512 -R 6f 73 3a 4c 69 6e 75 78 -W 2a 31 0d 0a 24 34 0d 0a 69 6e 66 6f 0d 0a 221.0.0.0/16 6379
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}