$re = '/[\{,]\s*"([^"]*)"\s*\:\s*"([^"]*)"/m';
$str = '{"d":{"results":[{"service manager":"Noelle April","turnover":"156"}
{"commission agent":"Elon Julius","turnover":"665"}
{"sales assistant":"Landen Boden","turnover":"585"}
{"sales manager":"Yisroel Armando","turnover":"826"}
{"service manager":"Hanna Lillie","turnover":"355"}
{"commission agent":"Memphis Malachi","turnover":"669"}
{"sales manager":"Araceli Nellie","turnover":"496"}
{"sales manager":"Cristian Sawyer","turnover":"819"}]}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);