const regex = /(ID.+)([\s\S]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(ID.+)([\\s\\S]+)', 'g')
const str = `ID_FIRST
After each id come one or more
lines with diverse text
ID_SECOND
The pattern repeats over and over
ID_THIRD
That's it
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}