use strict;
my $str = 'ID_FIRST
After each id come one or more
lines with diverse text
ID_SECOND
The pattern repeats over and over
ID_THIRD
That\'s it
';
my $regex = qr/(ID.+)([\s\S]+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}