package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([\u00A0-\uD7FF\uF900-\uFDCF\uFDF0-\uFFEFA-Za-z. \-]{0,55})$`)
var str = `Włodzisław S. Kulka`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}