re = /^([\u00A0-\uD7FF\uF900-\uFDCF\uFDF0-\uFFEFA-Za-z. \-]{0,55})$/
str = 'Włodzisław S. Kulka'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end